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As far as I know, most of these points are not covered in the TMG Users Guide, nor in
Getting the Most Out of The Master Genealogist (GTMOOTMG).
Controlling Which Spouses or Parents Appear on Descendant Charts

The information in this section applies to Descendant charts with
Chart Options > Chart Style > Orientation set to “Top to bottom”, and
Chart Options > Lines > Descendant Connections set to “UK style”. In this style,
couples appear side by side joined by a double line.
This information also applies to spouses of descendants in the Hourglass Chart with
Chart Style>Orientation of Ancestors set to “Top”.
Primary events are normally marked with a “ * “ on the event tag. For marriage tags, you
can mark any number of marriages (0, 1, 2, etc) as primary.
The number of spouses of a given descendant which show on a chart depends on two
factors, as illustrated in the Table:
Factors Controlling Spouses on Charts
Case #
1
2
3
4

Marriage marked as
primary?
yes
yes
no
no

Couple have known
children?
yes
no
yes
no

Spouse shows on
chart?
yes
yes
yes
no

The table shows that the only time a spouse of a descendant is not shown on a chart is
when the marriage is not marked as primary and the couple have no known children
(case 4).
[Terry Reigel also discussed “several ways to omit people who would otherwise appear
in any ancestry report or chart in TMG” (Wholly Genes Community Forum post, 3 Jan
2005). His discussion of non-primary marriages didn’t make the distinction between
cases 3 and 4 above. He also suggests using surety levels as a filter, but some of us don’t
have enough of these set to any value, and filtering by surety level might prevent some
birth and death events from appearing in the boxes. Terry’s list comes from pp. 117 118 of GTMOOTMG. ]
Controlling Where the Second Spouse Appears on the Chart

When you show two spouses of one descendant on a chart, the default is for the first
spouse to appear on the left, and the second on the right. However, when you are
producing a chart to be joined to another chart, you may wish to locate the second spouse
on the left. This is done by changing one of the two marriage sort dates so that the

second marriage has the earlier sort date. Descendant charts will now show the second
spouse on the left, since it is earliest by sort date, and events in the Person List are always
ordered by sort date, regardless of true date. (see “Chronological Sort” in the TMG help
file). To better display what is happening, you can choose to list tags in order of Sort
date instead of Date, by unchecking “Show date instead of sort date” in File>
Preferences> Program Options> Tag Box.
Effect of the Number of Known Parents

The number of “known” parents (parents recorded as parents in the project) affects what
is printed on the chart. These could include biological, step, foster, or adopting parents of
either sex. A child with only one known parent will be shown as the child of the known
parent and an “Unknown person” in a second box, with the two parents joined by the
double line.
If a child has two known parents in the project, both parents show on the descendant
chart, whether they are married or not. In other words, the double line really means one
of two things: they were a married couple (with or without children); or, they had
children together (whether they were married or not).
Three or more known parents might be recorded in the project. The most common case
in my family is where a person has three parents: one “Mother-Bio”, one “Father-Bio”,
and one “Father-Ado” (Adopting). In this case, the only father showing on the charts is
the father marked as primary (with the *). Thus, when there is an adopting father, you
can choose to show the adopting father instead of the biological father, if you wish.
Miscellaneous Comments about VCF

(1)
When moving boxes or extending lines, holding down the shift key forces the box
or line to move precisely horizontally or vertically (see “Moving Components” in the
VCF help file).
(2)
To avoid messed up lines when several boxes are moved, select and then group
everything you want to move before moving.
(3)
In VCF there are 37 standard and 69 fancy frames, with the latter requiring 24
MB of storage. To make all the frames available, you need to specifically select “fancy
frames” in the Select Components window of the TMG setup process. The setup process
can be re-run just to add the fancy frames.
(4)
One new feature of VCF that I would find useful would be the ability to
independently set each of the four chart margins to any specified size.
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Recommendations on File Formats and Printing for Visual ChartForm

Visual ChartForm (VCF) is a very powerful illustration program. The ability to join
several charts together is an extremely useful feature. In this way, you can make virtually
any chart you want, subject only to practical limits on the amount of work involved and
the size of the charts.
File Formats

VCF charts can be created in five different file formats. The five formats, and their
important characteristics, are compared in the Table. VC2 is the native format of VCF
charts, and files in the other four formats are generated from within VCF as shown in the
second column.
Characteristics of Different File Formats
File
Format

How created
or printed

Big chart
file size
(MB)

Big chart

Small chart

VC2

save as … or
print from VCF
print to virtual
printer

135

excellent

excellent

3.0

excellent

excellent

export to
export to
export to

2.7
28
135

poor
poor
onscreen terrible,
printed poor

photos & text grainy
photos & text grainy
excellent

PDF

JPG
BMP
EMF

Image quality

Notes

Wholly Genes
can print this
prefered by
commercial
printers

aspect ratio of
photos altered

The “virtual printer” used in “printing” the PDF format to a file refers to a pdf creator
program discussed in detail later. The export to JPG provided two adjustable
parameters: 1 < Quality < 100, and 0 < Smoothing < 65,000. The “best quality” JPG was
selected by setting Quality = 100 and Smoothing = 0. Other JPG settings produce
smaller file sizes at the expense of quality. The export to both the BMP and EMF
formats provided no adjustable parameters.
The “Big” chart used in the evaluation measures 16” x 66”, contains 74 individuals in
boxes (60 of them with colour head-and-shoulder images) and eight large colour images
added to the chart as decorations. The “Small” chart is a single 8.5” x 11” page
containing 14 individuals in boxes, 13 of them with head-and-shoulder images. The file
size for the big chart ranges from 2.7 MB for the JPG format to 135 MB for both the VC2
and EMF formats.
The image quality of the charts was examined for all twenty possible combinations of
parameters: two chart sizes, five file formats, and both presentation media (onscreen or
printed). Chart quality was normally found to be the same for the onscreen image and the
printed image; the only exception was the EMF files for the Big chart. Note that the
image quality of the three exported file formats (JPG, BMP, and EMF) was found to
depend on the chart size. The reason for this is not known.
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Other relevant information is included in the Notes column of the table. Wholly Genes’
ChartForm Delivery service can print from both VC2 and PDF, but they prefer the VC2
format. Large-format commercial printers prefer to work with the PDF format when
they have a choice. Finally, I found that the EMF format changed the aspect ratio
(height-to-width ratio) of the individual photos inside the boxes, as well as the aspect
ratio of the boxes themselves. For one representative photo, the measured aspect ratio
was 1.21 for the printed EMF image, compared to 1.30 for the original photo and the
printed versions of the other four formats. The faces in the printed EMF chart looked
slightly compressed vertically, and not quite natural.
Printing Charts

It is obvious from the table that the only two chart formats worth using are the VC2 and
the PDF formats – the other three fail in image quality and/or aspect ratio. The VC2
format is the best format to print from as long as you are printing onto small pages
accepted by your home color printer. You can also print economical large charts at home
from VCF as long as you don’t mind tapeing a number of small pages together – you can
show cut marks on these small charts. For printing large charts on a single large sheet of
paper, you can either use the Wholly Genes’ Chartform Delivery Service, accessed
through TMG/Report/Chart printing service, or you can “print” to a PDF file using a
virtual PDF printer, and take that file to a local commercial printer. If your local printer
works with the newer Cyan Magenta Yellow blacK (CMYK) colour mode, instead of the
older Red Green Blue (RGB) colour mode, you will need a PDF conversion program that
handles the CMYK colour mode.
I know of three options for performing the PDF conversion: buy the Adobe Acrobat
software (too expensive); use the free online conversion process at the Adobe web site
(nearly impossible to find); and convert using the PDFCreator program (the
recommended option because it works well, has no advertising, and supports the CMYK
colour mode).
The process of producing a chart from PDFCreator has four steps: download and install
PDFCreator; set the page size and virtual printer in VCF; print a pdf file using the color
mode; and take the file to your local printer for printing. The first three steps will now
be described in more detail.
First, find and load the latest version of PDFCreator from http://sourceforge.net/
projects/pdfcreator/ . As of May 2008, this is version 0.9.5. Download and install it.
Secondly, view the current paper size by choosing View / Page Bounds. The goal is to
set the paper size large enough that the whole chart is on one huge page, in which case no
page bound lines will be visible. In VCF, select File / Page Setup / Printer, and set
Printer Name to PDFCreator, and select printer Properties / Layout, and select Portrait or
Landscape orientation. Click Advanced to get the PDFCreator Advanced Options
window. Set Paper Size to Postscript Custom Page Size and enter the width and height
(any number up to 200 x 200 inches). Two hundred inches is 16.7 feet. Paper Feed
Direction seems to work equally well with either Short or Long edge first. Click OK to
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get back to Advanced Options, and set whatever you want for the other options. I use
Print Quality 600 dpi and leave all other features at the default values. This is also the
best place to re-size the drawing for printing: set Scaling to 100% or any other size you
want. Click OK four times in succession and you are back to the main VCF program.
Note that now no page bound lines are visible – the new size has taken effect.
Next, print the pdf file. Under File / Print you will see the Printer Name is PDFCreator
and the only print range showing is “All”. This confirms that your chart will be “all” on
one large page.
Press “OK” and wait for the processing to halt at the PDFCreator screen. (This takes
about 3 minutes for my 136 MB VCF chart on my computer). Under Options / Program
/ General Settings, set “Associate PDFCreator with postscript files”. Under Program /
Save, give the PDF file a name. Under Options / Formats / PDF / General Tab, set
Compatibility to the latest Acrobat version you have. Under the Colors Tab, select Color
Options = “Use Color Model Device CMYK” (or RGB, as desired), Press Save to finish
all the PDFCreator settings.
Back at PDFCreator 0.9.5, Save, enter a file name, and Save. This process takes about 1
minute on my computer with the same file.
Conclusions

The recommendation is to print small charts directly from VCF on your home colour
printer (if you have one), and to send large charts for printing to either Wholly Genes (in
the VCF format ) or to a local commercial printer (in the PDF format).
You can get good ideas for designing your charts by looking at the examples on the
Wholly Genes web site under “sample reports”.
It is easier to resize a chart for printing using PDFCreator, not the TMG resize command.
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