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Transferring from UFT to TMG5 

by Paul Lawrence 
 

An article I wrote on transferring data from UFT (Ultimate Family Tree) to 
TMG (The Master Genealogist, developed by WhollyGenes Software) 
appeared in the September 2000 issue of the RUG Newsletter. That article 
dealt with transferring UFT data to TMG version 4a. I have updated that 
article in regards to TMG version 5 to assist those UFT users who may be 
considering transferring to the current version of TMG. 

The only method available to transfer data to the majority of the existing 
genealogy programs is through the use of GEDCOM.  Unfortunately using 
GEDCOM to transfer UFT data may result in the lost of data that does not 

fit into the GEDCOM format. TMG is a program that is similar in concept to UFT and provides a 
direct transfer of UFT data via their GenBridge technology.  In 2000 WhollyGenes prepared a 
document that compared what data is transferred to TMG version 4 using GEDCOM versus what 
data is transferred using the GenBridge technology. The document also indicates where the 
transferred UFT data can be located in TMG once the transferred is made. This document is still 
relevant to transferring UFT data to TMG version 5. An Excel version or PDF version of this 
document is available for downloading at the WhollyGenes web site at 
http://www.whollygenes.com/downloads.htm. 

You should plan on importing your data several times and examining the results. You may find it 
easier to make any necessary changes to your data in UFT since you are more familiar with the 
program. Depending on the size of your database you may want to import just a representative 
subset of your data to become familiar with TMG and the import process.  Even after your final 
importation of UFT data there probably will be things that you will need to edit in TMG.  The 
amount of editing required will vary from user to user and depends on how you made use of some 
of UFT’s features. 

Although there are similarities between UFT and TMG, there are terminology differences, 
structural differences, and operational differences.  For example, in UFT you have Events plus 
additional data that is entered under the More button on the Individual Record window.  In TMG, 
basically all data is entered through “Tags”.  An event is a Tag.  Data that were contained in the 
More section in UFT, such as Common Name, Alias, Social Security Number, etc., are imported 
as Tags. UFT has individual projects. TMG version 5 also has individual projects but each project 
can consist of multiple data sets were a single data set equates to a single UFT project.  

Preparing Your UFT Project for GenBridge Import Into TMG 
There are a few things that you can do in UFT and TMG to prepare for an import.  First, TMG 
version 5 does not support GIF image format and they will not be imported. If you have GIF 
images in UFT you may want to change them to another format such as JPG prior to import. 

Second, if you have used a “old style date” format such as 4 January 1456/57 in UFT for dates 
prior to 1583 you will want to make a change in TMG Preferences>Program Options>General. 
The default date range for “old style dates” in TMG is 1583 to 1752. You will want to change the 
lower end of that range to a year earlier enough to cover any dates you may have entered in the 
above format. I changed mine to 100 to be safe. If you don’t make that change in Preferences then 
dates like the above will be imported as between dates such as “between 4 January 1456 and 
1457.” 
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Third, if you have used long free form dates in UFT they may be truncated in TMG.  TMG does 
not have a separate free form date field as UFT does but dates that do not conform to a normal 
date format can be entered as “irregular dates.”  However, the length of the date field (29 
characters) in TMG is shorter than the free form date field in UFT and your free form dates may 
be truncated. A list report summarizing the result of the import is created by TMG and will 
identify those dates that are truncated. You can use that report to locate those dates either in TMG 
or back in UFT, make appropriate adjustments, and then import your data again. 

You can import your data directly from a UFT project or from a backup (.sqz file) of your UFT 
project.  If you are importing from a backup, then that backup must contain all of your library and 
multimedia files as well as your project files.  TMG cannot import from one backup containing 
your project and another backup containing your library.  Importing from a backup also will take 
longer and use more temporary disk space as TMG has to expand the backup into a temporary 
directory prior to beginning the import process.  Unless you have a good reason for importing 
from a backup, I would import directly from your UFT project. 

Beginning the Import Process Using the Import Wizard 
To begin the import process click on the Import button in the Welcome window or, if you have a 
TMG project open select File>Import from the Menu Bar. You will be presented with the Import 
Wizard at Step 1: Welcome. You have two choices, Simple Wizard or Advanced Wizard. I 
suggest that you select the Advanced Wizard in order to step through all of the options available 
in importing UFT data. In most cases the default settings for UFT import will suffice but there are 
a few minor changes to the defaults that you may wish to make. Click the Next button to go to 
Step 2.  

In Step 2: Import from, you select the source of your import. Scroll down to the near the bottom 
of the “Import file type:” list and select the source of your import. Users of UFT and some of its 
predecessor products can select from Roots IV, Roots V, Ultimate Family Tree, and Visual Roots 
either the .PRO file of the 
.SQZ file. Once you have 
selected the type of file you 
wish to import you need to 
identify the specific file you 
wish to import. You can click 
on Autosearch to 
automatically search your 
system for all files of the 
specific type or click on 
Locate and navigate to the 
proper folder and select the 
correct file for import. I prefer 
to do the latter as to sit and 
wait for the search routine to 
search all active drives on the 
system. If you use the 
Autosearch the drop down 
“File to Import:” list is used 
to select the file from those found. Click Next to go to the next step. (Note: At any time you can 
click on Cancel to cancel the import process or click on Finish to skip the remaining steps and 
jump immediately to the last step to begin the import. You can also click on the Back button to 
return to the previous step and make adjustments if necessary.) 
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In Step 3: Import to, you identify the destination of your import. The default “Name of this data 
set:” is the file name of the data set being imported along with the date and time of the import. 
You may override this 
default by erasing and 
entering whatever name you 
wish to identify the data set. 
This name is used to 
identify the data set in the 
list of data sets with in the 
Data Set Manager in TMG. 
If you have initiated the 
import process from within 
an open TMG Project you 
will see two selections 
under the “Name of this 
data set:” field, “Add it to 
the current project” and 
Create a new project”. If 
you initiated the import 
process from the Welcome 
window meaning that there 
is no open TMG Project you will not see these two options as the only option is to create a new 
project. If you want to import you data set as a separate data set into the current open project in 
TMG select “Add it to the current project,” To create a new separate project select “Create a new 
project.” If you select the latter then the “New project name:”, “Put in folder:”, and “Collate 
sequence:” fields will be activated. Enter the name for the new project that will be used as the file 
name for the project. TMG has a default projects folder which can be changed under 
Preferences>Program Options>General, Default Project Path. I suggest leaving this set to the 
default projects folder but also recommend that you create subfolders for each of your projects 
within this default projects folder. To create a new subfolder type the name of the subfolder at the 
end of the path indicated in 
the “Put in folder:” line and 
tab out of the field. If the 
subfolder does not exist you 
will be asked if you wish to 
create a new folder, click 
Yes. For most users the 
“Collate sequence” does not 
need to be changed. Click 
Next to go to the next step. 

In Step 4: Ultimate Family 
Tree import option I, you 
make selections concerning 
the importation of dates and 
places. You can import the 
“Structure date” field or the 
“Free-form date” field. You 
will probably want to 
import the “Free-form date” field unless you have not made use this capability in UFT. If selected 
you need to indicated whether the date in the “Free-form date” field should be read as “month day 
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year” or “day month year”. Note that the Sort date also will be imported and will be placed in a 
similar Sort date field within TMG.  For Places the default settings are probably sufficient. By 
default, TMG will import the “Place” or the “Long Place” fields whichever is the longest. TMG 
will also import the “Short Place” field by default. TMG has a setting in Preferences>Program 
Options>New Project Defaults, Short place template: which identifies which place fields are to be 
used when “Short Place” is selected for reports. This template is overridden by the contents of the 
Short Place field in the Master Place List, the location where the UFT Short Place is placed upon 
import. Click Next to go to the next step. 

In Step 5: Ultimate Family Tree import option II, you select how your “Individual Research 
Notes” and “Event Research Notes” are to be imported. For Individual Research Notes, you can 
choose to have them import 
as a separate “Note tag,” 
import as “a memo to the 
primary Name tag,” or 
import as “a research task.”  
If you select “research task” 
you indicate whether to 
make one task per note or 
one task per paragraph. For 
Event Research Notes, you 
can choose to have them 
import as “a memo to the 
event,” or “import as a 
research task.”  If “research 
task” is selected, you again 
indicate whether to make 
one task per note or one 
task per paragraph. Click 
Next to go to the Next step. 

In Step 6: Ultimate Family Tree import option III, you make decisions concerning the 
importation of Event types and other miscellaneous items. The default settings are probably 
sufficient. You can import all of the event types in UFT or only those that you have used in the 
project being imported. If 
you wish to have all of the 
event types defined in UFT 
available you should change 
the default selection to 
“Import All.” Keep in mind 
that TMG probably has 
similar tag types that 
correspond to the UFT 
event types so “Import All” 
is probably not necessary. 
Those event types that are 
imported are matched to 
corresponding TMG tag 
types automatically where 
possible, i.e., birth to birth, 
death to death, marriage to 
marriage, etc. You also 
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have the option in the next step to match imported UFT event types to existing TMG tag types if 
desired or import them as completely new custom tag types for TMG. 

Under Other, there are several decisions to be made. 

1. Merge identical free notes (sources). Free notes from UFT are created as sources in 
TMG.  Selecting this option will merge those free notes from UFT that are identical into 
one source rather than having a source for each one. Default is checked. 

2. Merge repositories with the same name and different locations. This merges 
repositories with the same name into one repository record rather than multiple repository 
records. Default is checked. Note that if you have many repository fields such as “County 
Clerk” in various locations, you would be wise to uncheck this item. 

3. Import empty birth events (not required in TMG). Unlike UFT, TMG does not 
require that a birth event be present.  Default is unchecked. Unless you have some need to 
see a blank birth event, I would leave this selection unchecked. 

4. Import event/role templates (if off, TMG defaults will be used).  You should check 
this option to import your event/role templates as they appear in UFT. Default is checked. 
You also probably want to check to Add memo at the end of each template. Default is 
checked. Event text fields are imported as memo fields in the event tag in TMG. To 
ensure that they print after the event sentence as they do in UFT, you will need to check 
this item to add the Memo variable [M] to the end of the template sentence.  

5. Import source categories, components, and templates. Checked by default. If you 
uncheck this option then TMG defaults will be used. I recommend leaving this checked 
and at a latter clean up time convert the imported UFT sources to a TMG source. 

6. Convert Carriage Return (CR) plus space to CR+CR+Tab. In UFT a return plus a 
space was used to space between and indent paragraphs. Checking this converts these to 
codes to cause the same spacing in TMG. You will probably need to take a look at some 
of your longer text entries of multiple paragraphs to ensure that the formatting is as you 
desire. TMG uses codes for Carriage returns [:CR:] and Tabs [:TAB:] that can be inserted 
for formatting. Default setting is checked. 

7. Reuse place detail settings from last import. If checked subsequent imports will use the 
same settings as previously used for the place detail settings (discussed below.) Default is 
checked. 

 
Click Next to go to the next 
step. 

In Step 7: Tag Types option, 
you can assign UFT event 
types to a TMG tag type. 
Most are assigned 
automatically to a 
corresponding TMG tag type. 
For example, UFT Birth is 
assigned to TMG Birth, UFT 
Death is assigned to TMG 
Death, etc. UFT event types 
that are not assigned to TMG 
tag types will be created as 
custom tag types in TMG. For 
example, UFT Birth2 event 
type is not assigned to a TMG 
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tag type and will be created as a custom tag retaining the UFT sentence templates for the roles 
assigned to that tag. You also will see a Biography tag in the list. This is a custom tag that is 
created to contain the Individual Text for individuals in UFT. To assign a UFT event type to a 
TMG tag type highlight the unassigned event in the Imported tag types list and highlight the 
TMG tag type in the Standard tag types list and click Assign. Likewise you can unassign a UFT 
event type by highlighting it in the Imported tag types list and clicking Unassign. When you 
highlight an event in the Imported tag types list or in the Standard tag types the Tag Group that 
the event or tag has been assigned is shown at the bottom of the list. If you need to change the 
Tag Group that has been assigned to the Imported tag types click on Properties. Only unassigned 
Imported tag types can have their group changed. Also, when assigning an Imported tag type to a 
Standard tag type it must be assigned to a Standard tag type in the same group. The default 
settings in this step usually are sufficient and do not need to be changed. Click Next to go to the 
next step. 

In Step 8: Custom event types. Events in UFT have two detail fields, Detail A and Detail B.  
These detail fields have different meanings depending on the type of event.  When imported into 
TMG, they will be placed in 
either the Place Detail field 
or in the Memo field.  In 
some cases, such as the 
cemetery in a burial event, 
the detail field is 
appropriate for the TMG 
Place Detail field.  In other 
cases, such as the 
occupation and organization 
fields of an employment 
event, it is more appropriate 
to place them in the memo 
field.  It is possible to end 
up with two separate items 
in a Place Detail field of 
TMG and multiple items in 
the memo field of an event 
tag when you consider that there also may be event text. These multiple items are separated by 
two pipe symbols (||) and can be individually selected in the sentence structure by [Detail1] and 
[Detail2] variables, and [M1], [M2], [M3] variables respectively where [Detail1] and [M1] 
variables correspond to the UFT Detail A field, [Detail2] and [M2] variables correspond to the 
UFT Detail B field, and [M3] corresponds to the UFT event text. If the UFT Event did not make 
use of the Detail A or Detail B fields then the event text is place in the Memo field and 
represented by [M] in the sentence template. The imported UFT sentence templates are adjusted 
to reflect the proper variables according to the settings in this step.  During clean up in TMG 
never remove the pipe symbols (||) unless you have full understanding of the sentence structure 
and have made any adjustments to the variables contain within to reflect the removal of the pipes. 
The default settings in this step are probably sufficient and do not need to be changed. Click on 
Next to go to the final step. 

Step 9: Finish. At this point you will begin the import. If you have initiated the import from the 
Welcome window the only action in this step is to click Finish to begin the import process. If you 
initiated the import from the Menu selection File>Import from within an open TMG project then 
you must choose one of the following from the drop down list at the bottom of this window. 
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Do not open the project after import – the project will not be opened after import. 

Close current project and open imported project – the current open project will be 
closed and the imported project opened. 

Open the imported project in a separate window – the imported project will be opened 
in a separate window or separate instance of TMG version 5. You can have multiple 
copies of TMG 
version 5 opened at 
any time unlike UFT 
or TMG version 4, 
and the multiple 
instances of TMG can 
even have the same 
project open. 

After selecting on of the 
above click Finish to begin 
the import process. 

The time it takes to import 
your database will vary 
depending on the size of your 
database particularly the 
number of individuals and 
number of events, and the 
speed and resources of your 
computer. My database of over 32,000 names took approximately one and one-half hours to 
import on a Pentium IV 1.7 Ghz, 512MB of memory. 

After the Import Process Is Completed 
At the end of the import process, you are asked if you want to view the list file that shows any 
problems or comments on the import process. Click on Yes to view the list. If you wish to print 
the file, locate the file using Windows Explorer. It will be named with the project name you 
assigned in Step 3 with a .lst extension and is located in the project subfolder you selected at 
import. Double click on it to open it in Notepad. This list will indicate any problems that were 
found in the import process, show an import/conversion summary indicating where some of the 
data types were imported into TMG, indicate which UFT files were used in the conversion 
process, how long the import took, and what options were used in the import process. 

After opening the import list or responding No to opening the list, if you have chosen not to open 
the project in the final step of the import you will be returned to the previously opened project 
and the following actions will take place when you first open the imported project. Otherwise, 
TMG prepares to open the project and you are asked if you wish to have thumbnails created for 
your images. If you have a lot of images, thumbnails will speed up the processing of the Exhibit 
Log in TMG. If thumbnails are not created each time you open the Exhibit Log TMG has to 
create a thumbnail to display the image. The downside is that this increases the size of your 
backup as the thumbnails are part of the project data. You can turn the thumbnail feature on or off 
under Preferences>Project Options>Advanced but checking or unchecking “Save image 
thumbnails.” After responding to the thumbnail message, there will be a slight delay as TMG 
initializes files and builds various indices for the dataset. You will then be asked if you wish this 
data set to be Locked or Unlocked. You will want to select Unlocked as you cannot edit or make 
additions to a Locked data set. 
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You should examine your imported data thoroughly to determine any problems you may have 
with the way the data was imported. You may want to go back to UFT and make changes or 
corrections and rerun the import or rerun the import with different option settings. I would not do 
any massive editing or additions to your dataset until you feel comfortable with the way your data 
was imported. 

Recommended TMG Sources 
There are several sources that can be utilized to assist you in learning TMG. You may want to 
review some of these before you do your final import.  

• TMG-L mailing list on Rootsweb – this list is a user to user help list. To subscribe 
to TMG-L in the MAIL mode, send a message to <TMG-L-request@rootsweb.com> 
(to <TMG-D-request@rootsweb.com> for the Digest mode) with just the word 
"subscribe" (no quotes) in the text and turn off your signature. 

• TMG Tips – Tips and suggestions submitted by several experience users can be 
found at http://www.tmgtips.com/ . The web page is maintained by Lee Hoffman. 

• Terry’s TMG Tips – Web page of tips at http://tmg.reigelridge.com/ 

• WhollyGenes Community – Quoting WhollyGenes’ description of this site in their 
29 August 2004 Newsletter: “This extensive site is the new home for all of the 
important TMG resources, including Frequently Asked Questions (FAQ's), users 
groups, sample reports, TMG-related web sites, Tips & Hints and much more. The 
new discussion forums make it easy to get your questions answered directly from 
Wholly Genes technical support and experienced users. With the help of a powerful 
search feature, the message board also serves as a valuable knowledgebase of 
previous questions and answers - so it is a great place to start when you have a 
question that is not covered in the Users Guide or Help file.” Located at 
http://www.whollygenes.com/forums/ . 

• "Getting the Most Out of The Master Genealogist" – Compiled by Lee Hoffman 
this book contains chapters for various TMG subjects that have written by 
experienced TMG Users. The book can be purchased at 
http://www.whollygenes.com/gettingthemost.htm . 

• Video training tapes for TMG – Getting Started, Intermediate, or Advanced. The 
tapes can be purchased at http://www.whollygenes.com/videotapes.htm . 

 
These are just a few of the resources available in addition to the on-line Help within TMG and the 
Reference Manual provided with the project. You also should visit John Cardinal’s site for 
additional tools that can assist you in your use of TMG. His site is located at 
http://www.johncardinal.com/ . 


