TMG Family Reunion Reports

A

t our June meeting, Bob Velke returned for his second presentation this year. See our February 2012
newsletter for his January 2012 presentation featuring the debut of TMGv8. For this meeting we asked Bob
to focus on the report features in TMGv8. Rather than just showing how each report in TMG works, we asked
Bob to suggest how the reports in TMG can be used for a family reunion. The goal is to manage tasks associated
with the reunion, and perhaps generate materials to make the reunion interesting and fun for all attendees.
During the presentation, Bob described his personal experiences with reunions and several attendees added their
own observations. This article attempts to capture key concepts and provide an overall road map for using TMG
for a family reunion.
Not all the words are Bob’s, especially those regarding the filters and the “How-To”s. For any
discrepancies we apologize to Bob and to you. Let us know if you find any and send us your suggestions for
future publication in the newsletter.

Reunion Preparation
The first task would be to send out invitations to possible participants. If you have entered snail mail addresses
in TMG you can create a list using TMG. However, first we need to create a flag to identify the ancestors and their
living descendants who we want to attend. Bob used the SAMPLE.pjc, but this article uses generic examples
you can easily adapt to your own projects. We will set up a number of flags throughout this article, some we use
more than once. Right now we need a flag to identify two of the ancestors who are the focus of this reunion.
Frank’s descendants are flagged by ‘F’ in DESC_FAM, Harry’s descendants by ‘H’. Figure 1. Create a Flag
(DESC_FAM) to Identify the Descendants of a Person shows the flag definition screen.

Figure 1. Create a Flag (DESC_FAM) to Identify the Descendants of a Person
TMG automatically sets the flag to the default setting, ‘?’, when you close Flag Manager. Now we can use
descendants of Frank and Harry. You need to know their ID numbers. A simple List of ... People report will let
you set the flags for each ancestor line using Secondary Output and the flag DESC_FAM.
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Figure 2. Selection Criteria for a Descendant
The example above shows the filter to flag the reunion candidates. Click ‘OK’. Open the Options Tab and select
Secondary Output. Check the box ‘Change Flag’, select ‘DESC_FAM’ and fill in the value for the first ancestor, say
‘F’. If you are satisfied with the output to be flagged, respond ‘Y’ to the TMG prompt. Repeat the process for the
other ancestor, ‘H’. Don’t forget to uncheck the ‘Change Flag’ setting when you complete the last ancestor. You
can use as many ancestors as you need.
Now that the ancestors and their descendants have been identified and flagged we can get the invitations
ready to send.

Invitations
To generate an address list for invitations, the natural inclination would be to go to the Menu Report> List of...
>People, but to send invitations, the addresses of the people are required. Instead one needs to go Report> List
of...> Events.
Report Definition Screen – List of Events appears. The Configuration name is ‘List of Events’. Click the
radio button for Filtered group and type in the empty box Address List.
There are many addresses in the project so a filter needs to be created to select only those of interest. Use
Report> List of... Events. In the Report Definition Screen use the Add button, the name Address List was entered.
Pull down the selection arrow in the default entry ‘County’ and select ‘Tag Type Group’ near the
bottom. The default event filter group for Address appears. Because we need to add more criteria, change ‘END’
to ‘AND’ and pull down the selection arrow in the ‘Address’ line. Choose Principal1 from the drop down list. In
the Subfield select or type Living; in the Value field type Y. Continue building the filter as in Figure 3. Filter
Selection Criteria for the Address List below.
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Figure 3. Filter Selection Criteria for the Address List
Strictly observe the ‘AND’s, ‘OR’s, and parentheses. ‘OK’ button to quit the filter. Back on the Report Definition screen choose the Options tab, then the Output Column’s tab. Enter the fields that follow: ‘Prin1 Given,
Last’, detail, city, state, postal, etc. (Assume that the street address is in the detail field.) [You may need to
adjust the place fields to get the desired results in your address list. Select your Address List
Report>Options>Places>Use selected place fields and check or clear the fields needed to prepare your address
list.] See Figure 3a. Address List Output Format.
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Figure 3a. Address List Output Format
Next create an INVITE flag. It only has three entries: ‘?’, ‘N’, and ‘Y’. Prepare the flag as before. We’ll use it
shortly. Still in the Options area, switch to Secondary output. Check the ‘Change Flag’ box for the flag INVITE,
value ‘Y’. NOTE: You may want to delay setting the INVITE flag until you have run the report several times to
verify the output is want you want.
Back on the Report Definition screen: In the Report Destination area Click the radio button ‘Save to:’ and
in ‘File type:’ use the pull down arrow to select ‘Microsoft Excel v5 (XLS)’. On the ‘File name:’ line add the
name you want, like “Reunion Addresses 2012”. Then choose the Create Report button. A splash screen appears
with the records available and records that pass the criteria. When the output report appears, check the results for
their reasonableness. The address list results have been exported to Excel. See Figure 3b. Excel Output for
Address List.
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Figure 3b. Excel Output for Address List
WORD’s Mail Merge function can be used to add the addresses to a ‘boiler plate’ letter for each attendee and
also to prepare mailing labels. Mail Merge is beyond the scope of this discussion, but is described in your word
processor documentation. WORD’s Help for Mail Merge is very good.
Figure 3c. Example of Mailing Labels shows an example of the address labels produced from the Excel
Output using Mail Merge. The labels used are standard labels 1.33 inches by 4 inches and can be found
in most office supply stores.

Figure 3c. Example of Mailing Labels
Note that a filter is associated with a particular report, and is not always available for other reports.
Back to the reunion, now that invitation letters have been prepared and sent, you need to keep track of the
invitee’s responses. We will prepare an RSVP flag for that.

RSVP
The INVITE flag can assist in tracking invitee responses. The possible flag values are “?”, “Y”, and “N”.
Create the flag and set it to “Y” with the same criteria you used to create the Address List, i.e., Figure 3. Filter
Selection Criteria for the Address List. Setting the Project Explorer filter using the flag INVITE with value set
to ‘Y’ displays only those relatives who were sent an invitation. This makes it easier to locate and update the
RSVP flag for the invitees and also the RSVP flags of others living with the invitee’s family, like spouse, children,
and possibly others who also plan to attend.
To track the response of our invitees and family members, we’ll create a customized flag named RSVP.
From the Menu Toolbar select File>Flag Manager. See Figure 4. Create RSVP Flag below for the design.
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Figure 4. Create RSVP Flag
Again the Add button allows the creation of values shown in Figure 4. Create RSVP Flag. In this window four
possible values have been included. The order of appearance in the Values field is important since the first value ‘?’
- Unknown will be the default. [Note: ‘?’ is the standard for an unknown value.] The RSVP Flag will be set to ‘? ’ for
all records when the Flag Manager is closed.
As invitations are returned, the RSVP flag of the respondents can be changed to reflect their plans. Since the
responses will arrive sporadically, make the changes in status directly via the flag window as described in the
opening paragraph of this section. A response of “maybe” would call for additional reminder letters. Once the
deadline for responding has been reached, the resources required to support the participants can be ordered.

Name Tags
Name tags are essential to help people associate faces with names. Bob described his name tag format. He prints
first name followed by their surname on a line below. The last line of the name tag would be “descendant of ...”
(filling in an ancestor’s name). For those adults who are not direct descendants but are spouses, their third line
would be “Spouse of Descendant of ... ’’ (the ancestor’s name).
For the preparation of Nametags we will use two flags we created earlier, DESC_FAM and RSVP. We want the
descendants of Frank and Harry (from DESC_FAM) and we want to make name tags only for relatives who
have said they will attend (from RSVP). And we also want to retrieve the spouses of the descendants. With this
information we have enough to make the name tags. Use the filter in Figure 5. Filter Selection for Name Tags.
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Figure 5. Filter Selection for Name Tags
Note that the box for ‘Spouses’ is checked. Verify the accuracy of your report. Then send the report to Excel as
we did earlier for addresses. See Figure 5a. Name Tag Output Layout.
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Figure 5a. Name Tag Output Layout
There are a few edits to make to the Excel output. The lines below are a part of the total file. They have
been edited using the description below Figure 6. Excel Output.

Figure 6. Excel Output
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Column A contains the full name of descendants and non-descendant in Frank’s line. The entry in cell A2 is
included, even though, deceased) because spouses of descendants were retrieved. Column B was inserted into the
spread sheet to hold the surname. Column B is filled either by adding the married name of the female spouse
or by moving the Surname of a male entry from Column A. Column A is modified to show the maiden name of
female entries by including her surname in parentheses.
We will return to Column G later. Column J contains the name of the ancestor for all the descendants. This
name will be used to construct the third line of the name tag.
Before we describe the contents of Column G we need to learn a little about two functions of Excel: IF and
CONCATENATE.
The ‘IF’ function is made up of three arguments. The first argument is an expression to test, the second is an
output if the expression is true, and the third is an output if the expression is false. The arguments are separated
by commas. The cells in Column F are the arguments to test. The values in Column F are the flag values from
DESC_FAM. In this case the ‘?’ indicates the person is not a direct descendant and the F indicates the person is a
direct descendant of Frank. The second argument of the ‘IF’ function makes use of the CONCATENATE function; it adds two phrases together, “Spouse of “ and the phrase that is in cell J2, “Descendant of Frank C. Jones”;
the third argument of the ‘IF function uses the phrase in cell J2 as it is. So if we put all of these elements into
one formula, it looks like this. Note that an = sign precedes each computation in Excel.
=IF(F2=”?”, CONCATENATE(”Spouse of ”, $J$2), $J$2)
For the person in row 2, the expression to test is F2=”?”. The answer is true.
And that equates to “Spouse of Descendant of Frank C Jones”; it appears in cell G2 rather than the formula. The
reason for the $ before each element of the cell ID $J$2 is to keep it static as the formula is copied from cell G2 to the
last entry in cell (G19 in the total report). As we copy the formula down Column G, the cell number being tested in
Column F changes from F2 to F3 to F4 all the way to the bottom of the list. In Row 7 the formula would look like
this:
=IF(F7=”?”, CONCATENATE(”Spouse of ”, $J$2), $J$2)
To complete our edit we copy the formula in G2 into each cell down to the last entry. Then we complete the filling of
Column B with the surnames and parenthesizing the maiden names in Column A as described above.
Note: Frank and his wife Anna are the main focus of the reunion along with Frank’s brother Harry and his wife.
(The mailing list to descendants of Harry will be developed later in the preparation process.) They are spiritually
present, so a member of the family made the ‘yes’ RSVP for Frank. Anna is included because she is a spouse.
The elements we need for name tags are in Column A, B, and G, that is, the name tag’s First name in line 1,
Surname in line 2 and Relationship in line 3. An example follows in Figure 6a. Name Tag Examples. The name
tags use the same size labels as the address labels.

Figure 6a. Name Tag Examples
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Reports
A gathering of family members presents an opportunity to obtain missing information. Generate individual narrative
reports with ample space to allow participants to fill in the missing blanks. For each adult attendee make Individual
Narrative Reports for that person and their parents. Ask them to fill in the missing data. Bob said that people enjoy
the challenge of supplying missing data on the spot, but they do not like to read a lot of background information.
To obtain blank lines in the report for missing information, start with Report>Individual Narrative>
Options...>Miscellaneous>. Check the box ‘Blanks for missing data’. Review all the options, if no more than to see
what is available. Use large fonts, not everyone will have their reading glasses handy. One of the members in the
audience suggested adding a footer to allow the informant to give their name, date and e-mail address. Bob’s
approach was to use this new information as a lead that will be examined to find the original source. Bob didn’t
include the sources of the information with the narrative reports. Only a few people will be interested in those
details and if they express an interest, the information can be sent later.
On the day of the reunion, Bob takes pictures (head and shoulders) of participants as they arrive, and logs
the number of the photo against their names on a report generated beforehand of persons who replied yes to the
invitation. Bob did mention that he brings a printer to his reunions.
When the reunion covers more than one day, overnight Bob places the pictures on a large descendant box
chart. Bob said that people interested in the same thing tend to go off together, and only get together as a group
at dinner at night. As a game for the kids, he has them find their name on the descendant chart and sign their
name. Another attendee has found that a game like a scavenger hunt gets the children to mingle. By the time the
hunt is over the ice is broken and the kids have found new friends and met their older relatives. Bob makes a
quiz for children who try to find the answers by looking at the name tags or asking questions. This encourages
mixing since people now have several ready-made topics to start a conversation. The adults might favor a quiz
show panel format where whoever can answer the most questions gets a door prize. Questions are made, such as,
who lives in Florida, who has been married over 50 years, or who has a middle name of Andrew. Questions are
tailored based on the participants attending.

Family Group Sheets
Family Group sheets can also be used to collect missing information. Use bold print for surnames and large
fonts. Of course, include children and spouses.
Kinship reports can be useful for direct descendents. In Bob’s opinion reports that are long, like journal reports,
are not well received, and generate no useful information. Also the Relationship Chart between cousins,
Ahnentafels, and ancestor box charts were not useful.

10

Miscellany from Bob Velke’s Presentation
The topics below do not directly relate to preparing Reunion Reports; however, they were part of the
same presentation.

Audit
There is no special reason to execute an audit report for family reunion purposes but it is a matter of routine to
check the data for obvious errors. In the case that Bob illustrated, a birth discrepancy was highlighted where
the birth date was entered with the wrong century. In another case, Bob cited a death event after the death date.
In this case, Bob could not tell which was correct, and until that determination is made both were to be kept. If
you haven’t conducted an audit of your database, it’s time to do so. An additional check for distribution of
people might yield other insights in outlying values.

Accents
As a reminder, Bob color codes the ancestor flag. TMGv8 provides for colors on the tags. Bob used a case of
clergy designated with one color and military experience a second color. What would happen if a person were
both a veteran and a member of the clergy? Third color is now given as shown in the following figure.

Bob made the point about entering data in a query. He used state as an example. To obtain results one must use
the state as entered in the database; if the state data is stored as VA, a query using Virginia would fail. Bob suggested
querying using the “pipe” character, the straight vertical line, which appears uppercase above the enter key on
keyboards. For example, a query would be state = VA|VIRGINIA. The input is not case sensitive.
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Bob also mentioned that one can’t add new conditions on a query responding to a [?].
The Research Journal deserves attention. It is useful in citing not only what needs to be researched, but also what
was accomplished, which was not necessarily a success. A full treatment of this area needs further consideration. For
now note that upon entering the screen, the focus person is carried over to the screen.
Notice that in TMGv8 the drop down menu Report>List of ... >Events creates a selection in the drop down menu
labeled Address List in addition to List of Events. So Address List appears both in the box associated with
Configuration name and the drop down menu. This feature is new in TMGv8 and is not available in TMGv7.
If you find this feature annoying or confusing, Bob showed the group how to turn this feature off.
At the Menu bar, select File>Preferences>Reports (under “Program Options”); a screen appears on the right. Now
on the very last entry at the bottom of the screen, uncheck the box labeled “Show configurations on the Report menu”
as shown in the following figure.

This will cause TMGv8 to suppress the extra reports list in the drop down menus. With the box unchecked, TMGv8
acts like TMGv7 for this feature. Turn this feature on or off to suit your preferences.
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